Précédente Accueil Remonter Suivante

Langage informatique LOGO

Avec ce langage, en quelques lignes, on peut réaliser des merveilles !

 

Des exemples

Expérience avec des élèves

Documentation

Un vélo

 

Télécharger Logoplus de Dominique Bille (nouvelle version)

 

Des exemples

Avec des  carrés  :

 

;auteur Daniel CLERC 24/05/2006

pour poly :nf :long
repete :nf [av :long td 360 / :nf]
fin

pour des :nb
teste :nb <= 30
sivrai [stop]
sifaux [ poly 4 :nb av :nb / 15 td 5 ]
des :nb - (:nb / 15)
fin

pour joli :angle
teste :angle = 360
sivrai [stop]
sifaux [fcap :angle lc fpos [0 0] bc des 300 ]
joli :angle + 45
fin

ct fec 1 fcc 255
joli 0

 

Avec des  triangles  :

 

;auteur Daniel CLERC 25/05/2006

pour poly :nf :long
repete :nf [av :long td 360 / :nf]
fin

pour des :nb
teste :nb <= 10
sivrai [stop]
sifaux [ poly 3 :nb av :nb / 8 td 15 ]
des :nb - (:nb / 15)
fin

pour joli :angle
teste :angle >= 360
sivrai [stop]
sifaux [fcap :angle lc fpos [0 0] av 60 bc des 300 ]
joli :angle + 45
fin

ct
fec 1
fcc 255
joli 0

 

Avec des  cercles  :

;auteur Daniel CLERC 25/05/2006

pour un
fec 2
av 20 cercle 50 fec 1
av 20 cercle 60 av 20 cercle 70
av 20 cercle 80 av 20 cercle 90
av 20 cercle 100 av 20 cercle 110
av 20 cercle 120 fec 4 av 20 cercle 130
fin

pour deux
av 40 un re 50
fin

pour trois
lc fpos [-275 -25]
fcap 13 repete 10 [deux td 36 ]
fin

pour rosace
repete 6 [fec 1 cer td 30 fec 2 cer2 td 30]
fin

pour cer
repete 360 [av 1.2 td 1]
fin

pour cer2
repete 360 [av 1.35 td 1]
fin

trois origine bc fec 2 ct rosace

Avec des  polygones réguliers  :

 

 

;auteur Daniel CLERC

pour poly :nbfois :cote
repete :nbfois [av :cote td 360 / :nbfois]
fin

pour forme_1
fcc 242
lc av 100 tg 45 bc
repete 10 [poly 4 50 td 36]
lc td 90 av 170 bc
fcc 240
repete 10 [poly 6 45 td 36]
lc re 170 tg 45 re 100 bc
fin

pour dessin_2
repete 8 [forme_1 td 45]
fin

ct fec 2
dessin_2

 

Avec 1 ligne en plus, on arrive à cela :

 

 

;auteur Daniel CLERC

pour poly :nbfois :cote
repete :nbfois [av :cote td 360 / :nbfois]
fin

pour forme_1
fcc 242
lc av 100 tg 45 bc
repete 10 [poly 4 50 td 36]
lc td 90 av 170 bc
fcc 240
repete 10 [poly 6 45 td 36]
lc re 170 tg 45 re 100 bc
fin

pour dessin_2
repete 8 [forme_1 td 45]
fin

pour dessin_3
repete 3 [dessin_2 td 30]
fin

ct fec 1
dessin_3

 

 

Expérience avec le langage LOGO

Elèves du cours moyen

Ecole Guerton - 91 Ris Orangis

-> Documentation

En 1984, j’ai fait la visite du Centre Mondial de l’Informatique à Paris.

J’ai assisté à un cours sur la philosophie de LOGO.

Des séances avec ALOISE (Association Loisirs et Sciences Essonne) à Paris m’ont permis de me familiariser avec ce bel outil pour enseigner.

Durant le premier trimestre 1984, j’avais fait venir chez moi, durant quelques mercredis, deux élèves pour observer leur attitude face au langage LOGO.

En juin 1984, la mairie de Ris Orangis a équipé ma classe avec un ordinateur Goupil et le langage LOGO, un écran couleur et une imprimante.

Guy Préaux voulait voir ce qu’un enseignant motivé pouvait faire avec des enfants et un matériel « puissant et complet ».

Goupil et le langage Logo à l'école Guerton - 91 Ris Orangis

J’ai utilisé l’ordinateur Goupil plusieurs années au fond de ma classe.

Cette pédagogie deviendra encore plus efficace et plus facile à mettre en œuvre lorsque l’école Guerton s’est équipée d'une salle informatique.

 

Cette photo montre la richesse du langage et la créativité des élèves :

Rapport LOGO.pdf    Télécharger dossier Logo

 

 Programmation du dessin d'un vélo

Langage informatique LOGO

Le vélo est un objet géométrique !

Voici le listage des instructions :

 

pour velo
;auteur Daniel CLERC 20/02/2006
ve ct
;pédale gauche
lc fpos [-90 -16] bc pedale
;manivelle gauche
lc origine bc
fec 15 fcc 255 fcap 80 re 90
; roue av
lc fpos [288 40] bc roueav 150 18
; pignons & roue ar
lc fpos [-200 40] bc fec 1 fcc 255
pignon 0
rouear 150 10
;freins
freinar freinav
; cadre & pédalier
lc origine bc cadre 240 ; 64
; potence & guidon
lc fpos [185 300] bc
potence
guidon
poignee
direction
serrageselle
;selle
lc fpos [-95 320] bc
selle
lc origine bc
pedalier
chaine
derailleur
derailleurav
; blocage
lc fpos [288 40] bc
fcc 255 fec 5 cercle 3 fcc 1 fec 1 cercle 1
lc fpos [-200 40] bc
fcc 255 fec 5 cercle 3 fcc 1 fec 1 cercle 1
fin

pour serrageselle
lc fpos [-87 248] bc
fec 8 fcc 255 fcap 72 av 15 lc re 13 bc fcc 0 fec 2 cercle 1
fin

pour derailleurav
lc fpos [-20 58] bc
fcc 248 fec 7 fcap 343  av 10
lc fpos [-50 31] bc
fec 5 fcap 34 fcc 243 repete 7 [av 2 td 2]
fec 7 repete 8 [av 2 td 2]
fec 9 repete 8 [av 2 td 2]
fin

pour direction
lc fpos [181 277] bc
fec 4 fcc 243 fcap 72 av 20
lc fpos [202 208] bc fcap 71 av 20
fin

pour poignee
fcc 255 fec 2
lc fec 1 fpos [280 311] fcap 82 bc av 25 tg 55 av 20 td 35 av 10
td 30 av 10 td 30 av 15 td 90 av 12 td 90 av 10 tg 90 av 15 tg 45 av 10
td 90 av 10
repete 10 [av 2 tg 8]
td 179 repete 40 [av 1 tg 2]
lc re 10 remplis
fcc 243
td 190 av 38 fcap 180 bc av 30 fcap 145 av 30
tg 90 av 7 tg 90 av 20 fcap 0 av 45 fcap 30 av 20 lc re 25
remplis
fin

pour freinar
lc fpos [-145 180] bc
fcap 112
fcc 243 fec 8
av 25 re 12 fcap 45 av 20
fec 12 cercle 2 tg 10 fec 5 av 18 fcc 255 fec 7 av 5
fin

pour freinav
lc fpos [255 188] bc fcc 243 fec 8
fcap 255 av 25 re 12
fcap 330 av 20
fec 12 cercle 2 td 10 fec 5 av 18 fcc 255 fec 7 av 5
fin

pour chaine
lc origine bc fec 3 fcc 255 bc
cercle 50
lc re 50 bc
fcap 276
av 205
repete 21 [av 1 td 7]
av 16
repete 15 [av 1 tg 7]
av 30
repete 35 [av 1 td 4]
fcap 91 lc av 10 bc av 183
fin

pour derailleur
; galets
lc fpos [-202 -20] bc
fec 5 fcc 248
cercle 7 fcc 255 cercle 4 fec 2 fcc 1 cercle 1 fcc 248 fec 5
lc fpos [-198 2] bc
cercle 7 fcc 255 cercle 4 fec 2 fcc 1 cercle 1 fcc 248 fec 5
;derailleur
lc fpos [-203 28] bc
fec 8 fcap 210
fcc 243 av 25
fec 5  av 6 td 90 fcc 255 av 10 re 10 tg 90
lc re 31
cercle 4 fcc 255 cercle 2 fec 2 fcc 1 cercle 1 fcc 248
lc av 20 bc
fcc 243
fec 10 fcap 100 av 3 fec 12 av 3 fec 13 av 3
av 3 fec 14 av 3 fec 15 av 3 fec 16 av 3 fec 17 av 3
fin

pour guidon
fcap 100 fec 17 fcc 8 av 30
repete 70 [av 1 td 2]
av 30 fcap 260 av 20
fin

pour roueav :ray :nbray
;valve
fec 4 fcc 255
fcap hasard 360
lc av :ray - 10 bc av 10  lc re :ray bc
td ( 360 / :nbray ) / 2
;rayons
fec 2
repete :nbray [av :ray re :ray td 360 / :nbray ]
;jante
fec 6 fcc 248 ; gris foncé
cercle :ray + 3
;pneu
fcc 230 fec 10 ;vert 230
cercle :ray + 10
fcc 255 fec 4
cercle :ray + 16
fin

pour rouear :ray :nbray
;valve
fcap 46 fec 4 fcc 255
lc av :ray - 10 bc av 10  lc re :ray bc
fcap 0
;rayons
fec 2
repete :nbray [ av 10 td 95 av :ray re :ray  tg 95 re 10 td 360 / :nbray ]
td 92
repete :nbray [ av 10 tg 95 av :ray re :ray  td 95 re 10 td 360 / :nbray ]
;jante
fec 6 fcc 248 ; gris foncé
cercle :ray + 3
;pneu
fcc 230 fec 10 ;vert 230
cercle :ray + 10
fcc 255 fec 4
cercle :ray + 16
fin

pour cadre :coul
fcc :coul fec 13 fcap 0
; tube de selle
tg 90 - 73 av 265
;tige de selle
fcc 255 fec 11 av 80 
; chariot
tg 10 av 5
fcc 243 fec 8 cercle 5
lc re 5 td 10 re 90 bc
; tube horizontal
fcc :coul fec 12 fcap 85 av 270
; tube de direction
fec 19 td 90 - (90 - 78) re 10 av 67
fec 15
; fourche
av 10 tg 5 av 75 tg 5 av 105
lc re 105 td 5 re 75 td 5 re 25 bc
; tube diagonale
fcc :coul fec 14 fpos [0 0]
; base
fcap 281 fec 10 av 208
;patte dérailleur
fcap 175 av 15 re 15
fec 9
; hauban
fcap 33 av 245
fin

pour pedalier
;plateaux
lc origine bc
fec 4 fcc 248 ;gris
cercle 32
fec 4
cercle 46 ;cercle 23
;branches
fec 12 cercle 8
fcap 45
repete 5
   [
     fec 10 bc av 30
fec 5 fcc 255 cercle 1 fec 2 fcc 0 cercle 1
lc av 4 bc
fcc 248 fec 4
tg 60 av 18 re 18 td 120 av 18 re 18 tg 60
lc re 34 td 360 / 5
   ]
; manivelles droite
fec 15 fcc 255
bc fcap 80 av 90

;pédale droite
lc fpos [89 15] bc pedale

fin

pour pedale
fcap 180 fec 4 fcc 248
td 90
fec 10 av 10 re 20 av 10
fec 4 fcc 1 cercle 1
fin

pour pignon :nb
teste :nb = 20 sivrai [ stop ] sifaux [ cercle :nb ]
pignon :nb + 2
fin

pour selle
fec 2 fcc 254
lc fpos [-180 350] bc
fcap 55 av 10 td 34 av 123 td 50 av 10 td 120 av 15
td 10 av 50 tg 25 av 38 td 55 av 42
lc re 42 tg 55 re 13
bc fcap 90 fcc 248 fec 4 av 25 tg 27 av 22
lc av 10 fcc 255 remplis
fin

pour potence
fec 18 fcc 255 fcap 340
av 5 re 18 av 13
fcap 80 av 60
fin



velo

L'adresse du site de l'auteur du langage LOGO utilisé : www.flucas.com

Il n'est plus téléchargeable.

 

Précédente Accueil Remonter Suivante